<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en">
<![endif]-->
<!--[if (!IE)]><!-->
<html lang="en">
<!--<![endif]-->

<head>
<meta charset="UTF-8" />
<title>&#8220;Gangster&#8221; driver in deadly hit &amp; run crash says &#8220;people hit and run people all the time&#8221; | Fellowship of the Minds</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://fellowshipoftheminds.com/xmlrpc.php" />
<meta name="google-site-verification" content="pXgaENXFQy3i2qKOxz4_PzF3LZXuCyWQm1pMWQb-Hpk" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=fellowshipoftheminds.com&amp;id=11081320&amp;t=1528476693&amp;back=https%3A%2F%2Ffellowshipoftheminds.com%2F2018%2F06%2F08%2Fgangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//fellowshipofminds.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Fellowship of the Minds &raquo; Feed" href="https://fellowshipoftheminds.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Fellowship of the Minds &raquo; Comments Feed" href="https://fellowshipoftheminds.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Fellowship of the Minds &raquo; &#8220;Gangster&#8221; driver in deadly hit &amp; run crash says &#8220;people hit and run people all the&nbsp;time&#8221; Comments Feed" href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1516999477h&ver=4.9.7-alpha-43298"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJyNUtFSwyAQ/CGRiTb65PgthJzk2oNjApm0fy+EaE2N2Be4ZXa5vQU5e6HZRXBR2kl4mgy6IGev2YpgkeBygx51CA9yX0Z4giCPEL3SJ7GgGn0EUhF64TnEG1STaR4hnVuvYmZY6FEBgU20mmzG3kDqkyhrLSKcqxLrX74a5XJIU1WdlaC6zo8QgkirxcmKOCRv/0xks/uS2GJwc1KkKB1HTOrwXfy6s7SSfupySorQgQzxQnAXE50ubLEMck+Ykf36fPttdiSBNSoSZZKfoCY2wIJYq4jsNkB8kMKx/ss6YpNKsyR7hTWR0vnyTo3XqkbPERQnMgxqzL3WvaZah092eAv+eq3hIA1xpygT3u1b0z61r017aJ6PnwPJbYk=?cssminify=yes' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyFj90KwjAMhV/IrAw6xQvxWWoXS2r/bNoNfXo70At1KARCTr4cTsScgIJ2dUQWttW1Yr49W2d5I34B4MlkVbDzFF6wjqFgKAvr44kcQmXMyjStGZ3jCpciF4/MDVrZvkeiMBHOfzGLJSl9gYxM9y9XXyG5aiiwyOjaAyMsGT6mdnX0h17uh36Qcre1DyuucHk='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1522184747h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://fellowshipofminds.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Trump-hater celebrity-chef Anthony Bourdain committed&nbsp;suicide' href='https://fellowshipoftheminds.com/2018/06/08/celebrity-chef-anthony-bourdain-committed-suicide/' />
<link rel='next' title='Bill Clinton confronted at book event about Lolita Express to pedo&nbsp;island' href='https://fellowshipoftheminds.com/2018/06/08/bill-clinton-confronted-at-book-event-about-lolita-express-to-pedo-island/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/" />
<link rel='shortlink' href='https://wp.me/pKuKY-GUw' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Ffellowshipoftheminds.com%2F2018%2F06%2F08%2Fgangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Ffellowshipoftheminds.com%2F2018%2F06%2F08%2Fgangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="&#8220;Gangster&#8221; driver in deadly hit &amp; run crash says &#8220;people hit and run people all the time&#8221;" />
<meta property="og:url" content="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/" />
<meta property="og:description" content="Good thing this guy was stupid enough to speak to a reporter on camera about the incident. From Fox News: A driver who was arrested Wednesday after a deadly hit-and-run crash in Boston made no apol…" />
<meta property="article:published_time" content="2018-06-08T14:30:31+00:00" />
<meta property="article:modified_time" content="2018-06-07T19:00:53+00:00" />
<meta property="og:site_name" content="Fellowship of the Minds" />
<meta property="og:image" content="https://fellowshipofminds.files.wordpress.com/2018/06/phocian-fitts.jpg" />
<meta property="og:image:width" content="960" />
<meta property="og:image:height" content="482" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@DrEowyn" />
<meta name="twitter:text:title" content="&#8220;Gangster&#8221; driver in deadly hit &amp; run crash says &#8220;people hit and run people all the&nbsp;time&#8221;" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@DrEowyn" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/b44e87079ce3dd384b698212658e7198?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/b44e87079ce3dd384b698212658e7198?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/b44e87079ce3dd384b698212658e7198?s=114" />
<link rel='openid.server' href='https://fellowshipofminds.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://fellowshipofminds.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://fellowshipoftheminds.com/osd.xml" title="Fellowship of the Minds" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
				<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="Fellowship of the Minds" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="&quot;In a time of universal deceit, telling the truth is a revolutionary act.&quot;" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://fellowshipoftheminds.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/b44e87079ce3dd384b698212658e7198?s=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="Good thing this guy was stupid enough to speak to a reporter on camera about the incident. From Fox News: A driver who was arrested Wednesday after a deadly hit-and-run crash in Boston made no apologies before he was taken into custody, saying it was just an &quot;unfortunate situation.&quot; The Boston Police Department said in a&hellip;" />
	<style type="text/css">
			#site-title a,
		#site-description {
			color: #0000f4 !important;
		}
		</style>
	<link rel="amphtml" href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s2.wp.com/?custom-css=1&#038;csblog=KuKY&#038;cscache=6&#038;csrev=4" />
		</head>

<body class="post-template-default single single-post postid-164952 single-format-standard mp6 customizer-styles-applied two-column content-sidebar highlander-enabled highlander-light">
<div id="container" class="hfeed contain">
	<div id="header">
		<div id="masthead" role="banner">
						<div id="site-title">
				<span>
					<a href="https://fellowshipoftheminds.com/" title="Fellowship of the Minds" rel="home">Fellowship of the Minds</a>
				</span>
			</div>
			<div id="site-description">&quot;In a time of universal deceit, telling the truth is a revolutionary act.&quot;</div>
		</div><!-- #masthead -->

		<div id="access" role="navigation">
		  			<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">Skip to content</a></div>
						<div class="menu"><ul>
<li ><a href="https://fellowshipoftheminds.com/">Home</a></li><li class="page_item page-item-2"><a href="https://fellowshipoftheminds.com/about/">About</a></li>
<li class="page_item page-item-59175"><a href="https://fellowshipoftheminds.com/angels-and-saints/">Angels &amp; Saints</a></li>
<li class="page_item page-item-81898"><a href="https://fellowshipoftheminds.com/boston-marathon-bombings/">Boston Marathon Bombings</a></li>
<li class="page_item page-item-106866"><a href="https://fellowshipoftheminds.com/christianinspirational/">Christianity</a></li>
<li class="page_item page-item-112598"><a href="https://fellowshipoftheminds.com/false-flags/">Conspiracies/False Flags</a></li>
<li class="page_item page-item-73317"><a href="https://fellowshipoftheminds.com/dysfunctional-govt-economy/">Corrupt USA/World</a></li>
<li class="page_item page-item-30884"><a href="https://fellowshipoftheminds.com/gardens-of-the-fellowship/">Creation</a></li>
<li class="page_item page-item-44167"><a href="https://fellowshipoftheminds.com/election-2012/">Elections</a></li>
<li class="page_item page-item-45156"><a href="https://fellowshipoftheminds.com/health/">Health, Finance &amp;&nbsp;Security</a></li>
<li class="page_item page-item-9540"><a href="https://fellowshipoftheminds.com/illegal-immigration/">Illegal Immigration/Refugees</a></li>
<li class="page_item page-item-71882"><a href="https://fellowshipoftheminds.com/internet-rumors-true-or-false/">Internet Hoaxes/Bugs</a></li>
<li class="page_item page-item-10230"><a href="https://fellowshipoftheminds.com/islam/">Islam/Jews</a></li>
<li class="page_item page-item-11546"><a href="https://fellowshipoftheminds.com/leftwing-pathology/">Leftwing Pathology</a></li>
<li class="page_item page-item-27203"><a href="https://fellowshipoftheminds.com/creeping-big-brotherism/">Police State/NWO</a></li>
<li class="page_item page-item-86682"><a href="https://fellowshipoftheminds.com/black-racism-race-riots/">Racism</a></li>
<li class="page_item page-item-2194"><a href="https://fellowshipoftheminds.com/prayer-to-st-michael/">St. Michael’s Prayer against evil</a></li>
<li class="page_item page-item-145719"><a href="https://fellowshipoftheminds.com/syria-war/">Syria War</a></li>
<li class="page_item page-item-6714"><a href="https://fellowshipoftheminds.com/the-obama-chronicles/">The Obama Chronicles</a></li>
<li class="page_item page-item-141355"><a href="https://fellowshipoftheminds.com/the-trump-presidency/">The Trump Presidency</a></li>
</ul></div>
		</div><!-- #access -->

		<div id="branding">
						<a href="https://fellowshipoftheminds.com/">
									<img src="https://fellowshipofminds.files.wordpress.com/2016/12/cropped-cropped-st-michael-rooftop-statue1.jpg" width="990" height="366" alt="" />
							</a>
					</div><!-- #branding -->
	</div><!-- #header -->

	<div id="content-box">

<div id="content-container">
	<div id="content" role="main">

	
		<div id="nav-above" class="navigation">
			<div class="nav-previous"><a href="https://fellowshipoftheminds.com/2018/06/08/celebrity-chef-anthony-bourdain-committed-suicide/" rel="prev"><span class="meta-nav">&larr;</span> Trump-hater celebrity-chef Anthony Bourdain committed&nbsp;suicide</a></div>
			<div class="nav-next"><a href="https://fellowshipoftheminds.com/2018/06/08/bill-clinton-confronted-at-book-event-about-lolita-express-to-pedo-island/" rel="next">Bill Clinton confronted at book event about Lolita Express to pedo&nbsp;island <span class="meta-nav">&rarr;</span></a></div>
		</div><!-- #nav-above -->

		<div id="post-164952" class="post-164952 post type-post status-publish format-standard hentry category-crime-2 category-idiots category-media category-social-media category-taxes-economy category-united-states tag-boston tag-boston-police tag-facebook tag-hit-and-run-car-crash tag-massachusetts tag-vehicular-homicide">

			
			<h1 class="entry-title">&#8220;Gangster&#8221; driver in deadly hit &amp; run crash says &#8220;people hit and run people all the&nbsp;time&#8221;</h1>
							<div class="entry-meta">
					<span class="meta-prep meta-prep-author">Posted on</span> <a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/" title="7:30 am" rel="bookmark"><span class="entry-date">June 8, 2018</span></a> <span class="by-author"><span class="sep">by</span> <span class="author vcard"><a class="url fn n" href="https://fellowshipoftheminds.com/author/dcgere/" title="View all posts by DCG" rel="author">DCG</a></span> </span><span class="comments-link"><span class="meta-sep">|</span> <a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/#comments">8 Comments</a></span>
									</div><!-- .entry-meta -->
			
			<div class="entry-content">
				<div data-shortcode="caption" id="attachment_164953" style="width: 522px" class="wp-caption aligncenter"><img data-attachment-id="164953" data-permalink="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/phocian-fitts/" data-orig-file="https://fellowshipofminds.files.wordpress.com/2018/06/phocian-fitts.jpg?w=512&#038;h=257" data-orig-size="960,482" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="phocian fitts" data-image-description="" data-medium-file="https://fellowshipofminds.files.wordpress.com/2018/06/phocian-fitts.jpg?w=512&#038;h=257?w=300" data-large-file="https://fellowshipofminds.files.wordpress.com/2018/06/phocian-fitts.jpg?w=512&#038;h=257?w=500" class="alignnone  wp-image-164953" src="https://fellowshipofminds.files.wordpress.com/2018/06/phocian-fitts.jpg?w=512&#038;h=257" alt="phocian fitts" width="512" height="257" srcset="https://fellowshipofminds.files.wordpress.com/2018/06/phocian-fitts.jpg?w=512&amp;h=257 512w, https://fellowshipofminds.files.wordpress.com/2018/06/phocian-fitts.jpg?w=150&amp;h=75 150w, https://fellowshipofminds.files.wordpress.com/2018/06/phocian-fitts.jpg?w=300&amp;h=151 300w, https://fellowshipofminds.files.wordpress.com/2018/06/phocian-fitts.jpg?w=768&amp;h=386 768w, https://fellowshipofminds.files.wordpress.com/2018/06/phocian-fitts.jpg 960w" sizes="(max-width: 512px) 100vw, 512px" /><p class="wp-caption-text">Phocian Fitts: Not the brightest gangster on the block</p></div>
<p>Good thing this guy was stupid enough to speak to a reporter on camera about the incident.</p>
<p>From <a href="http://www.foxnews.com/us/2018/06/07/driver-in-deadly-hit-and-run-crash-says-accidents-happen-and-people-hit-and-run-people-all-time.html">Fox News</a>: <strong>A driver who was arrested Wednesday after a deadly hit-and-run crash in Boston made no apologies before he was taken into custody, saying it was just an &#8220;unfortunate situation.&#8221;</strong></p>
<p>The Boston Police Department <a href="http://bpdnews.com/news/2018/6/6/community-alert-boston-police-seeking-the-publics-help-into-investigation-of-fatal-hit-and-run-motor-vehicle-crash-in-brighton-g57ep">said in a news release</a> Phocian Fitts, 23, of Brighton, Mass. <strong>was arrested on charges of motor vehicular homicide and leaving the scene of an accident after causing death</strong>.</p>
<p>The crash happened around 12:50 p.m. on Commonwealth Avenue, <strong>where police said that Fitts struck the victim, a man in his 80&#8217;s, and then kept driving</strong>. Police took Fitts in for questioning sometime after the crash but was released. The victim’s name has not been released.</p>
<p><strong>Hours later, <a href="https://www.fox25boston.com/news/-accidents-happen-driver-in-fatal-hit-run-says-he-s-done-nothing-wrong/764491442">Boston 25 News reporter Drew Karedes found Fitts</a>, who confessed on camera to leaving the scene of the crash after striking the man.</strong></p>
<p>&#8220;<strong>I</strong> <strong>was listening to my music and as I was driving I was driving too quick</strong>, I was driving too quick to the point where I couldn’t really stop and it was a green light,&#8221; Fitts told Boston 25 News. &#8220;As the guy was walking, the light was green, I’m driving and pressing the horn, pressing the horn beep beep,<strong> it was either I was going to die and crash into a pole. When it came down to it accidents happen.</strong>&#8221;</p>
<p>The 23-year-old told Boston 25 in the exclusive interview that he is not &#8220;stone-cold killer.&#8221;</p>
<p>&#8220;I didn&#8217;t do nothing on purpose,&#8221; he told the television station. &#8220;<strong>People hit and run people all the time</strong>, it just happened to be an unfortunate situation where I was driving.&#8221;</p>
<p>Fitts spoke to <a href="https://www.fox25boston.com/news/-i-m-not-worried-driver-makes-no-apologies-for-fatal-hit-and-run/764694121">Boston 25 News</a> still wearing the disposable suit given to him during police questioning after his clothes were seized as potential evidence. <strong>The news station reported that police did not have enough evidence to arrest Fitts initially until he spoke to the Boston 25 reporter.</strong></p>
<p><strong>When asked if he should have stopped after striking the man, Fitts stood by his decision.</strong></p>
<p>&#8220;<strong>First off, I was scared and worried</strong> because I didn&#8217;t know what can happen, that&#8217;s why I left I said God forbid, I hope he&#8217;s OK,&#8221; he told Boston 25. &#8220;<strong>I&#8217;m a real gangster, I&#8217;m a real gangster not in a bad way. I’m a gangster because I help out the community and I look out for the youth. </strong>I know that’s why everybody got my back, my family. I&#8217;m not scared. It is what it is.&#8221;</p>
<p>Boston Police said they are reviewing area surveillance video to check the green light, and are asking anyone who witnessed the crash to contact them.</p>
<p>DCG</p>
<div id="jp-post-flair" class="sharedaddy sd-rating-enabled sd-like-enabled sd-sharing-enabled"><div class="sd-block sd-rating"><h3 class="sd-title">Rate this:</h3><div class="pd-rating" id="pd_rating_holder_1006935_post_164952"></div></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-164952" class="share-facebook sd-button share-icon" href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-164952" class="share-linkedin sd-button share-icon" href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-164952" class="share-twitter sd-button share-icon" href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon" href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-164952" class="share-google-plus-1 sd-button share-icon" href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-164952" class="share-pinterest sd-button share-icon" href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon" href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-skype"><a rel="nofollow" data-shared="sharing-skype-164952" class="share-skype sd-button share-icon" href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?share=skype" target="_blank" title="Click to share on Skype"><span>Skype</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://api.whatsapp.com/send?text=%22Gangster%22%20driver%20in%20deadly%20hit%20%26%20run%20crash%20says%20%22people%20hit%20and%20run%20people%20all%20the%20time%22 https%3A%2F%2Ffellowshipoftheminds.com%2F2018%2F06%2F08%2Fgangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time%2F" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-telegram"><a rel="nofollow" data-shared="" class="share-telegram sd-button share-icon" href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?share=telegram" target="_blank" title="Click to share on Telegram"><span>Telegram</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-11081320-164952-5b1ab4153d98b' data-src='//widgets.wp.com/likes/index.html?ver=20180319#blog_id=11081320&amp;post_id=164952&amp;origin=fellowshipofminds.wordpress.com&amp;obj_id=11081320-164952-5b1ab4153d98b' data-name='like-post-frame-11081320-164952-5b1ab4153d98b'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>							</div><!-- .entry-content -->

			<div class="entry-info">
							This entry was posted in <a href="https://fellowshipoftheminds.com/category/crime-2/" rel="category tag">crime</a>, <a href="https://fellowshipoftheminds.com/category/idiots/" rel="category tag">Idiots</a>, <a href="https://fellowshipoftheminds.com/category/liberalsdemocratsleft/media/" rel="category tag">Media</a>, <a href="https://fellowshipoftheminds.com/category/liberalsdemocratsleft/media/social-media/" rel="category tag">social media</a>, <a href="https://fellowshipoftheminds.com/category/economy-2/taxes-economy/" rel="category tag">Taxes</a>, <a href="https://fellowshipoftheminds.com/category/united-states/" rel="category tag">United States</a> and tagged <a href="https://fellowshipoftheminds.com/tag/boston/" rel="tag">Boston</a>, <a href="https://fellowshipoftheminds.com/tag/boston-police/" rel="tag">Boston Police</a>, <a href="https://fellowshipoftheminds.com/tag/facebook/" rel="tag">Facebook</a>, <a href="https://fellowshipoftheminds.com/tag/hit-and-run-car-crash/" rel="tag">hit and run car crash</a>, <a href="https://fellowshipoftheminds.com/tag/massachusetts/" rel="tag">Massachusetts</a>, <a href="https://fellowshipoftheminds.com/tag/vehicular-homicide/" rel="tag">vehicular homicide</a>. Bookmark the <a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/" title="Permalink to &#8220;Gangster&#8221; driver in deadly hit &amp; run crash says &#8220;people hit and run people all the&nbsp;time&#8221;" rel="bookmark">permalink</a>.							</div><!-- .entry-info -->
		</div><!-- #post-## -->

		<div id="nav-below" class="navigation">
			<div class="nav-previous"><a href="https://fellowshipoftheminds.com/2018/06/08/celebrity-chef-anthony-bourdain-committed-suicide/" rel="prev"><span class="meta-nav">&larr;</span> Trump-hater celebrity-chef Anthony Bourdain committed&nbsp;suicide</a></div>
			<div class="nav-next"><a href="https://fellowshipoftheminds.com/2018/06/08/bill-clinton-confronted-at-book-event-about-lolita-express-to-pedo-island/" rel="next">Bill Clinton confronted at book event about Lolita Express to pedo&nbsp;island <span class="meta-nav">&rarr;</span></a></div>
		</div><!-- #nav-below -->

		
<div id="comments">

	
			<h3 id="comments-title">
			8 responses to &ldquo;<span>&#8220;Gangster&#8221; driver in deadly hit &amp; run crash says &#8220;people hit and run people all the&nbsp;time&#8221;</span>&rdquo;		</h3>

		
		<ol class="commentlist">
				<li class="comment byuser comment-author-traildustfotm even thread-even depth-1 highlander-comment" id="li-comment-748329">
		<div id="comment-748329">
		<div class="comment-author vcard">
			<img alt='' src='https://2.gravatar.com/avatar/26acbf761ba5244a8c6617b3bbfa3a9a?s=48&#038;d=wavatar&#038;r=G' class='avatar avatar-48' height='48' width='48' />
			<cite class="fn">traildustfotm</cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/#comment-748329">
				June 8, 2018 at 7:45 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?replytocom=748329#respond' onclick='return addComment.moveForm( "comment-748329", "748329", "respond", "164952" )' aria-label='Reply to traildustfotm'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>Great article, DCG. When I heard this guy excusing himself, I couldn&#8217;t believe my ears. Where&#8217;s his soul, his empathy? Instead of grieving for the guy he ran over, he started bragging about what a good guy he is, about being &#8220;a real gangster not in a bad way.&#8221; (!!!!!) And he said, &#8221; …God forbid, I hope he’s OK.&#8221;</p>
<p id="comment-like-748329" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?like_comment=748329&#038;_wpnonce=2874c932e4" class="comment-like-link needs-login" rel="nofollow" data-blog="11081320"><span>Like</span></a><span id="comment-like-count-748329" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="4">4 people</a></span></p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="comment byuser comment-author-traildustfotm odd alt thread-odd thread-alt depth-1 highlander-comment" id="li-comment-748335">
		<div id="comment-748335">
		<div class="comment-author vcard">
			<img alt='' src='https://2.gravatar.com/avatar/26acbf761ba5244a8c6617b3bbfa3a9a?s=48&#038;d=wavatar&#038;r=G' class='avatar avatar-48' height='48' width='48' />
			<cite class="fn">traildustfotm</cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/#comment-748335">
				June 8, 2018 at 7:51 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?replytocom=748335#respond' onclick='return addComment.moveForm( "comment-748335", "748335", "respond", "164952" )' aria-label='Reply to traildustfotm'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>On another point, I was disgusted to see in Boston, right next to the police headquarters, when the pedestrians walk sign comes on, so does the green light for the drivers. I chalk that up to the complete lack of accountability of government workers. I don&#8217;t know about other cities, but Boston gives cushy jobs to a lot of &#8220;connected&#8221; people who should be behind bars. Boston is one of the most crooked places I know.</p>
<p id="comment-like-748335" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?like_comment=748335&#038;_wpnonce=9d107c5b6c" class="comment-like-link needs-login" rel="nofollow" data-blog="11081320"><span>Like</span></a><span id="comment-like-count-748335" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="3">3 people</a></span></p>
</div>

	</div><!-- #comment-##  -->

	<ul class="children">
	<li class="comment byuser comment-author-dcgere bypostauthor even depth-2 highlander-comment" id="li-comment-748366">
		<div id="comment-748366">
		<div class="comment-author vcard">
			<img alt='' src='https://0.gravatar.com/avatar/077726e4d88c858321e6b597eb038bb7?s=48&#038;d=wavatar&#038;r=G' class='avatar avatar-48' height='48' width='48' />
			<cite class="fn"><a href='https://fellowshipofminds.wordpress.com' rel='external nofollow' class='url'>DCG</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/#comment-748366">
				June 8, 2018 at 8:58 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?replytocom=748366#respond' onclick='return addComment.moveForm( "comment-748366", "748366", "respond", "164952" )' aria-label='Reply to DCG'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>Broward  County might give Boston a run for that title&#8230;</p>
<p id="comment-like-748366" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?like_comment=748366&#038;_wpnonce=87cda7baa4" class="comment-like-link needs-login" rel="nofollow" data-blog="11081320"><span>Like</span></a><span id="comment-like-count-748366" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
	<li class="comment byuser comment-author-brianheinz56 odd alt thread-even depth-1 highlander-comment" id="li-comment-748338">
		<div id="comment-748338">
		<div class="comment-author vcard">
			<img alt='' src='https://0.gravatar.com/avatar/61a50fccf49ac1e74c38d16ed6fe4909?s=48&#038;d=wavatar&#038;r=G' class='avatar avatar-48' height='48' width='48' />
			<cite class="fn"><a href='https://fellowshipoftheminds.com' rel='external nofollow' class='url'>Brian Heinz</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/#comment-748338">
				June 8, 2018 at 7:55 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?replytocom=748338#respond' onclick='return addComment.moveForm( "comment-748338", "748338", "respond", "164952" )' aria-label='Reply to Brian Heinz'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>Seems life is not important to the youth of today. When we look at what they teach in school and the peer pressure of teens you can understand why there is no God in any of their learning in the school or on the street.</p>
<p id="comment-like-748338" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?like_comment=748338&#038;_wpnonce=f18f3d8bf9" class="comment-like-link needs-login" rel="nofollow" data-blog="11081320"><span>Like</span></a><span id="comment-like-count-748338" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="2">2 people</a></span></p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="comment even thread-odd thread-alt depth-1 highlander-comment" id="li-comment-748347">
		<div id="comment-748347">
		<div class="comment-author vcard">
			<img alt='' src='https://1.gravatar.com/avatar/d2b8c715ff5e3c9231c9d3faeb8af556?s=48&#038;d=wavatar&#038;r=G' class='avatar avatar-48' height='48' width='48' />
			<cite class="fn"><a href='http://deleted' rel='external nofollow' class='url'>TPR</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/#comment-748347">
				June 8, 2018 at 8:18 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?replytocom=748347#respond' onclick='return addComment.moveForm( "comment-748347", "748347", "respond", "164952" )' aria-label='Reply to TPR'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>A news reporter doing a real community service for a change by finding the guy, &amp; letting him spill his guts, saving the cops the trouble.</p>
<p>If Mr. Gangsta was &#8220;driving too quick,&#8221; as he said, he may have been &#8220;driving too quick&#8221; beyond the speed limit.  Even if it was an &#8220;accident,&#8221; I&#8217;m sick of hearing elderly people suffering for the stupid acts of others.  This guy&#8217;s victim was 80!  How sad!</p>
<p>Saw another story yesterday; a male home health aid hired to care for a 96-yo man forced the very elderly man to do oral sex on the creep!  Thankfully a family member walked in &amp; caught the perv in the act &amp; had him arrested.  Even the chief of police was thoroughly disgusted at such behavior against a very old man.</p>
<p>Callous &amp; sicko freaks everywhere!</p>
<p id="comment-like-748347" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?like_comment=748347&#038;_wpnonce=b50bec4bde" class="comment-like-link needs-login" rel="nofollow" data-blog="11081320"><span>Like</span></a><span id="comment-like-count-748347" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="3">3 people</a></span></p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="comment odd alt thread-even depth-1 highlander-comment" id="li-comment-748358">
		<div id="comment-748358">
		<div class="comment-author vcard">
			<img alt='' src='https://1.gravatar.com/avatar/4a2e5258ecfdef755096b915bbfd708a?s=48&#038;d=wavatar&#038;r=G' class='avatar avatar-48' height='48' width='48' />
			<cite class="fn">Alma</cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/#comment-748358">
				June 8, 2018 at 8:43 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?replytocom=748358#respond' onclick='return addComment.moveForm( "comment-748358", "748358", "respond", "164952" )' aria-label='Reply to Alma'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>In the King James Version of the Bible the text reads:<br />
Therefore all things whatsoever ye would that men should do to you:<br />
do ye even so to them: for this is the law and the prophets.  Mathew 7:12.<br />
The law in this case is applicable and because he is soooo stupid not to know there are no good gangsters, what a retard.</p>
<p id="comment-like-748358" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?like_comment=748358&#038;_wpnonce=e30e465ea6" class="comment-like-link needs-login" rel="nofollow" data-blog="11081320"><span>Like</span></a><span id="comment-like-count-748358" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="2">2 people</a></span></p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="comment byuser comment-author-sushieq even thread-odd thread-alt depth-1 highlander-comment" id="li-comment-748369">
		<div id="comment-748369">
		<div class="comment-author vcard">
			<img alt='' src='https://1.gravatar.com/avatar/a15303fecdd1dfe49563f4a9b7dc9405?s=48&#038;d=wavatar&#038;r=G' class='avatar avatar-48' height='48' width='48' />
			<cite class="fn"><a href='http://recynd.wordpress.com' rel='external nofollow' class='url'>Recynd77</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/#comment-748369">
				June 8, 2018 at 9:23 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?replytocom=748369#respond' onclick='return addComment.moveForm( "comment-748369", "748369", "respond", "164952" )' aria-label='Reply to Recynd77'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>I may be pushing the boundaries of allowed speech with this, but I’ve noticed that hit-and-runs are quite common in areas with a high percentage of Mexican illegals.  I don’t know if it’s because many drive without licenses and/or insurance, if they drive drunk and/or high more than the rest of us, if they’re more inclined to panic, or don’t value human life (since many come from large Catholic families, this is hard to believe), or are too stupid for the responsibility that comes with piloting a two(?)-ton projectile (the car), I can’t say.  However, I think Santa Ana, CA might be the hit-and-run capital of the world.</p>
<p id="comment-like-748369" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?like_comment=748369&#038;_wpnonce=9dec6eea88" class="comment-like-link needs-login" rel="nofollow" data-blog="11081320"><span>Like</span></a><span id="comment-like-count-748369" class="comment-like-feedback">Like</span></p>
</div>

	</div><!-- #comment-##  -->

	<ul class="children">
	<li class="comment byuser comment-author-sushieq odd alt depth-2 highlander-comment" id="li-comment-748373">
		<div id="comment-748373">
		<div class="comment-author vcard">
			<img alt='' src='https://1.gravatar.com/avatar/a15303fecdd1dfe49563f4a9b7dc9405?s=48&#038;d=wavatar&#038;r=G' class='avatar avatar-48' height='48' width='48' />
			<cite class="fn"><a href='http://recynd.wordpress.com' rel='external nofollow' class='url'>Recynd77</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/#comment-748373">
				June 8, 2018 at 9:36 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?replytocom=748373#respond' onclick='return addComment.moveForm( "comment-748373", "748373", "respond", "164952" )' aria-label='Reply to Recynd77'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>I just looked it up: Santa Ana is terrible but Anaheim is worse.  If you wanna save your life, don’t ride a bike in Orange County!</p>
<p id="comment-like-748373" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/?like_comment=748373&#038;_wpnonce=eae4ec5988" class="comment-like-link needs-login" rel="nofollow" data-blog="11081320"><span>Like</span></a><span id="comment-like-count-748373" class="comment-like-feedback">Like</span></p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		</ol>

		
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://fellowshipoftheminds.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="6ce5f1f76e" /><input type="hidden" name="_wp_http_referer" value="/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">
	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" class="nascar-signin-link"
                   title="Login via Guest">
									</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" class="nascar-signin-link"
                   title="Login via WordPress.com">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg>				</a>
			</li>
			<li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" class="nascar-signin-link"
                   title="Login via Twitter">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" class="nascar-signin-link"
                   title="Login via Facebook">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg>				</a>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=wavatar&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=wavatar&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
						<p class="comment-form-posting-as pa-wordpress">
			<strong></strong>
			You are commenting using your WordPress.com account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=wavatar&amp;forcedefault=y&amp;r=G" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
						<p class="comment-form-posting-as pa-googleplus">
			<strong></strong>
			You are commenting using your Google+ account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" x="0px" y="0px" viewBox="0 0 60 60" ><path fill="#519bf7" d="M56.3,30c0,-1.6 -0.2,-3.4 -0.6,-5h-3.1H42.2H30v10.6h14.8C44,39.3 42,42 39.1,43.9l8.8,6.8C53,46 56.3,39 56.3,30z" /><path fill="#3db366" d="M30,57.5c6.7,0 13.1,-2.4 17.9,-6.8l-8.8,-6.8c-2.5,1.6 -5.6,2.4 -9.1,2.4c-7.2,0 -13.3,-4.7 -15.4,-11.2l-9.3,7.1C9.8,51.3 19.1,57.5 30,57.5z" /><path fill="#fdc600" d="M5.3,42.2l9.3,-7.1c-0.5,-1.6 -0.8,-3.3 -0.8,-5.1s0.3,-3.5 0.8,-5.1l-9.3,-7.1C3.5,21.5 2.5,25.6 2.5,30S3.5,38.5 5.3,42.2z" /><path fill="#f15b44" d="M40.1,17.4l8,-8C43.3,5.1 37,2.5 30,2.5C19.1,2.5 9.8,8.7 5.3,17.8l9.3,7.1c2.1,-6.5 8.2,-11.1 15.4,-11.1C33.9,13.7 37.4,15.1 40.1,17.4z" /></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=wavatar&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
						<p class="comment-form-posting-as pa-twitter">
			<strong></strong>
			You are commenting using your Twitter account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=wavatar&amp;forcedefault=y&amp;r=G" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
						<p class="comment-form-posting-as pa-facebook">
			<strong></strong>
			You are commenting using your Facebook account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg></span>
		</p>
		w
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='164952' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="0c0d015cf4" /></p>
<input type="hidden" name="genseq" value="1528476693" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="115"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>
</div><!-- #comments -->
	
	</div><!-- #content -->
</div><!-- #content-container -->


		
		<div id="primary" class="widget-area" role="complementary">
					<ul class="xoxo">

					<li id="recent-posts-2" class="widget-container widget_recent_entries">		<h3 class="widget-title">Recent Posts</h3>		<ul>
											<li>
					<a href="https://fellowshipoftheminds.com/2018/06/08/bill-clinton-confronted-at-book-event-about-lolita-express-to-pedo-island/">Bill Clinton confronted at book event about Lolita Express to pedo&nbsp;island</a>
									</li>
											<li>
					<a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/">&#8220;Gangster&#8221; driver in deadly hit &amp; run crash says &#8220;people hit and run people all the&nbsp;time&#8221;</a>
									</li>
											<li>
					<a href="https://fellowshipoftheminds.com/2018/06/08/celebrity-chef-anthony-bourdain-committed-suicide/">Trump-hater celebrity-chef Anthony Bourdain committed&nbsp;suicide</a>
									</li>
											<li>
					<a href="https://fellowshipoftheminds.com/2018/06/08/liberal-utopia-chicago-leads-us-in-underwater-homes/">Liberal utopia: Chicago leads US in underwater&nbsp;homes</a>
									</li>
											<li>
					<a href="https://fellowshipoftheminds.com/2018/06/07/stunning-new-study-found-human-and-all-animal-species-today-originated-only-100000-to-200000-years-ago/">Stunning new study found human and all animal species today originated only 100,000 to 200,000 years&nbsp;ago</a>
									</li>
											<li>
					<a href="https://fellowshipoftheminds.com/2018/06/07/hollyweird-tries-another-all-female-lead-cast-movie-with-oceans-8/">Hollyweird tries another all-female lead cast movie with &#8220;Ocean&#8217;s 8&#8221;</a>
									</li>
											<li>
					<a href="https://fellowshipoftheminds.com/2018/06/07/fight-for-15-mcdonalds-to-add-self-order-kiosks-to-1000-stores-each-quarter/">Fight for $15! McDonald&#8217;s to add self-order kiosks to 1,000 stores each&nbsp;quarter</a>
									</li>
											<li>
					<a href="https://fellowshipoftheminds.com/2018/06/07/michigan-state-u-health-physicist-joseph-hattey-arrested-for-dog-rape/">Michigan State U. health physicist Joseph Hattey arrested for dog&nbsp;rape</a>
									</li>
											<li>
					<a href="https://fellowshipoftheminds.com/2018/06/07/political-correctness-at-work-miss-america-is-ending-the-swimsuit-competition/">Political correctness at work: Miss America is ending the swimsuit&nbsp;competition</a>
									</li>
											<li>
					<a href="https://fellowshipoftheminds.com/2018/06/07/dog-says-i-love-you-2/">Dog says &#8216;I love&nbsp;you&#8217;</a>
									</li>
											<li>
					<a href="https://fellowshipoftheminds.com/2018/06/06/double-standards-black-actress-issa-rae-wears-a-belt-with-the-n-word/">Double standards: Black actress Issa Rae wears a belt with the&nbsp;N-word</a>
									</li>
											<li>
					<a href="https://fellowshipoftheminds.com/2018/06/06/fright-of-the-day-whoopi-goldberg-at-council-of-fashion-designers-of-america-awards/">Fright of the Day: Whoopi Goldberg at Council of Fashion Designers of America&nbsp;awards</a>
									</li>
											<li>
					<a href="https://fellowshipoftheminds.com/2018/06/06/2018-california-primary-election-results/">2018 California Primary Election&nbsp;Results</a>
									</li>
											<li>
					<a href="https://fellowshipoftheminds.com/2018/06/06/parkland-students-plan-bus-tour-to-target-places-where-nra-bought-and-paid-for-politicians/">Parkland students plan bus tour to target places where NRA &#8220;bought and paid for politicians&#8221;</a>
									</li>
											<li>
					<a href="https://fellowshipoftheminds.com/2018/06/06/astonishing-athleticism-of-cats/">Astonishing athleticism of&nbsp;cats</a>
									</li>
					</ul>
		</li><li id="recent-comments-2" class="widget-container widget_recent_comments"><h3 class="widget-title">Recent Comments</h3>				<table class="recentcommentsavatar" cellspacing="0" cellpadding="0" border="0">
					<tr><td title="marblenecltr" class="recentcommentsavatartop" style="height:32px; width:32px;"><a href="http://necltr.wordpress.com" rel="nofollow"><img alt='' src='https://2.gravatar.com/avatar/b3e4f8f465083fbf529f0795fce16627?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></td><td class="recentcommentstexttop" style=""><a href="http://necltr.wordpress.com" rel="nofollow">marblenecltr</a> on <a href="https://fellowshipoftheminds.com/2018/06/08/celebrity-chef-anthony-bourdain-committed-suicide/comment-page-1/#comment-748379">Trump-hater celebrity-chef Ant&hellip;</a></td></tr><tr><td title="Mike Warren (@mdwarren67)" class="recentcommentsavatarend" style="height:32px; width:32px;"><a href="http://twitter.com/mdwarren67" rel="nofollow"><img alt='' src='https://1.gravatar.com/avatar/186121ea9406612e65966291d8f6e11c?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></td><td class="recentcommentstextend" style=""><a href="http://twitter.com/mdwarren67" rel="nofollow">Mike Warren (@mdwarr&hellip;</a> on <a href="https://fellowshipoftheminds.com/2018/06/08/celebrity-chef-anthony-bourdain-committed-suicide/comment-page-1/#comment-748378">Trump-hater celebrity-chef Ant&hellip;</a></td></tr><tr><td title="Maryaha" class="recentcommentsavatarend" style="height:32px; width:32px;"><a href="http://freeindeed484.wordpress.com" rel="nofollow"><img alt='' src='https://0.gravatar.com/avatar/0aaf63a57f9351266e751c4f208250d9?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></td><td class="recentcommentstextend" style=""><a href="http://freeindeed484.wordpress.com" rel="nofollow">Maryaha</a> on <a href="https://fellowshipoftheminds.com/2018/06/08/bill-clinton-confronted-at-book-event-about-lolita-express-to-pedo-island/comment-page-1/#comment-748377">Bill Clinton confronted at boo&hellip;</a></td></tr><tr><td title="Recynd77" class="recentcommentsavatarend" style="height:32px; width:32px;"><a href="http://recynd.wordpress.com" rel="nofollow"><img alt='' src='https://1.gravatar.com/avatar/a15303fecdd1dfe49563f4a9b7dc9405?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></td><td class="recentcommentstextend" style=""><a href="http://recynd.wordpress.com" rel="nofollow">Recynd77</a> on <a href="https://fellowshipoftheminds.com/2018/06/08/bill-clinton-confronted-at-book-event-about-lolita-express-to-pedo-island/comment-page-1/#comment-748376">Bill Clinton confronted at boo&hellip;</a></td></tr><tr><td title="cogitoergosumantra" class="recentcommentsavatarend" style="height:32px; width:32px;"><a href="http://cogitoergosumantra.wordpress.com" rel="nofollow"><img alt='' src='https://1.gravatar.com/avatar/784a881895e046f7e0dbe97a2ad4a73a?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></td><td class="recentcommentstextend" style=""><a href="http://cogitoergosumantra.wordpress.com" rel="nofollow">cogitoergosumantra</a> on <a href="https://fellowshipoftheminds.com/2018/06/08/celebrity-chef-anthony-bourdain-committed-suicide/comment-page-1/#comment-748375">Trump-hater celebrity-chef Ant&hellip;</a></td></tr><tr><td title="kommonsentsjane" class="recentcommentsavatarend" style="height:32px; width:32px;"><a href="http://kommonsentsjane.wordpress.com" rel="nofollow"><img alt='' src='https://2.gravatar.com/avatar/8aeee22ba9c87136b92c3658811be677?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></td><td class="recentcommentstextend" style=""><a href="http://kommonsentsjane.wordpress.com" rel="nofollow">kommonsentsjane</a> on <a href="https://fellowshipoftheminds.com/2018/06/08/bill-clinton-confronted-at-book-event-about-lolita-express-to-pedo-island/comment-page-1/#comment-748374">Bill Clinton confronted at boo&hellip;</a></td></tr><tr><td title="Recynd77" class="recentcommentsavatarend" style="height:32px; width:32px;"><a href="http://recynd.wordpress.com" rel="nofollow"><img alt='' src='https://1.gravatar.com/avatar/a15303fecdd1dfe49563f4a9b7dc9405?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></td><td class="recentcommentstextend" style=""><a href="http://recynd.wordpress.com" rel="nofollow">Recynd77</a> on <a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/comment-page-1/#comment-748373">&#8220;Gangster&#8221; driver&hellip;</a></td></tr><tr><td title="vistabee1" class="recentcommentsavatarend" style="height:32px; width:32px;"><img alt='' src='https://0.gravatar.com/avatar/f962fc516e22acae7818ebcc0970703d?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></td><td class="recentcommentstextend" style="">vistabee1 on <a href="https://fellowshipoftheminds.com/2018/06/08/bill-clinton-confronted-at-book-event-about-lolita-express-to-pedo-island/comment-page-1/#comment-748372">Bill Clinton confronted at boo&hellip;</a></td></tr><tr><td title="Recynd77" class="recentcommentsavatarend" style="height:32px; width:32px;"><a href="http://recynd.wordpress.com" rel="nofollow"><img alt='' src='https://1.gravatar.com/avatar/a15303fecdd1dfe49563f4a9b7dc9405?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></td><td class="recentcommentstextend" style=""><a href="http://recynd.wordpress.com" rel="nofollow">Recynd77</a> on <a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/comment-page-1/#comment-748369">&#8220;Gangster&#8221; driver&hellip;</a></td></tr><tr><td title="DCG" class="recentcommentsavatarend" style="height:32px; width:32px;"><a href="https://fellowshipofminds.wordpress.com" rel="nofollow"><img alt='' src='https://0.gravatar.com/avatar/077726e4d88c858321e6b597eb038bb7?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></td><td class="recentcommentstextend" style=""><a href="https://fellowshipofminds.wordpress.com" rel="nofollow">DCG</a> on <a href="https://fellowshipoftheminds.com/2018/06/08/celebrity-chef-anthony-bourdain-committed-suicide/comment-page-1/#comment-748368">Trump-hater celebrity-chef Ant&hellip;</a></td></tr><tr><td title="cogitoergosumantra" class="recentcommentsavatarend" style="height:32px; width:32px;"><a href="http://cogitoergosumantra.wordpress.com" rel="nofollow"><img alt='' src='https://1.gravatar.com/avatar/784a881895e046f7e0dbe97a2ad4a73a?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></td><td class="recentcommentstextend" style=""><a href="http://cogitoergosumantra.wordpress.com" rel="nofollow">cogitoergosumantra</a> on <a href="https://fellowshipoftheminds.com/2018/06/08/celebrity-chef-anthony-bourdain-committed-suicide/comment-page-1/#comment-748367">Trump-hater celebrity-chef Ant&hellip;</a></td></tr><tr><td title="DCG" class="recentcommentsavatarend" style="height:32px; width:32px;"><a href="https://fellowshipofminds.wordpress.com" rel="nofollow"><img alt='' src='https://0.gravatar.com/avatar/077726e4d88c858321e6b597eb038bb7?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></td><td class="recentcommentstextend" style=""><a href="https://fellowshipofminds.wordpress.com" rel="nofollow">DCG</a> on <a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/comment-page-1/#comment-748366">&#8220;Gangster&#8221; driver&hellip;</a></td></tr><tr><td title="saintquinn" class="recentcommentsavatarend" style="height:32px; width:32px;"><img alt='' src='https://2.gravatar.com/avatar/8d176bb7f821007943379ebd94765595?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></td><td class="recentcommentstextend" style="">saintquinn on <a href="https://fellowshipoftheminds.com/2018/06/08/celebrity-chef-anthony-bourdain-committed-suicide/comment-page-1/#comment-748365">Trump-hater celebrity-chef Ant&hellip;</a></td></tr><tr><td title="Alma" class="recentcommentsavatarend" style="height:32px; width:32px;"><img alt='' src='https://1.gravatar.com/avatar/4a2e5258ecfdef755096b915bbfd708a?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></td><td class="recentcommentstextend" style="">Alma on <a href="https://fellowshipoftheminds.com/2018/06/07/stunning-new-study-found-human-and-all-animal-species-today-originated-only-100000-to-200000-years-ago/comment-page-1/#comment-748364">Stunning new study found human&hellip;</a></td></tr><tr><td title="saintquinn" class="recentcommentsavatarend" style="height:32px; width:32px;"><img alt='' src='https://2.gravatar.com/avatar/8d176bb7f821007943379ebd94765595?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></td><td class="recentcommentstextend" style="">saintquinn on <a href="https://fellowshipoftheminds.com/2018/06/08/celebrity-chef-anthony-bourdain-committed-suicide/comment-page-1/#comment-748363">Trump-hater celebrity-chef Ant&hellip;</a></td></tr>				</table>
				</li><li id="top-posts-2" class="widget-container widget_top-posts"><h3 class="widget-title">Most read posts</h3><ul>				<li>
										<a href="https://fellowshipoftheminds.com/2018/06/08/celebrity-chef-anthony-bourdain-committed-suicide/" class="bump-view" data-bump-view="tp">
						Trump-hater celebrity-chef Anthony Bourdain committed suicide					</a>
									</li>
							<li>
										<a href="https://fellowshipoftheminds.com/2017/09/28/obama-ketchup-is-acceptable-on-hotdogs-until-age-8/" class="bump-view" data-bump-view="tp">
						Obama: &#039;ketchup is acceptable on hotdogs until age 8&#039;					</a>
									</li>
							<li>
										<a href="https://fellowshipoftheminds.com/2018/06/07/michigan-state-u-health-physicist-joseph-hattey-arrested-for-dog-rape/" class="bump-view" data-bump-view="tp">
						Michigan State U. health physicist Joseph Hattey arrested for dog rape					</a>
									</li>
							<li>
										<a href="https://fellowshipoftheminds.com/2018/06/05/california-new-law-will-limit-water-use-to-55-gal-day-per-person/" class="bump-view" data-bump-view="tp">
						California: New law will limit water use to 55 gal/day per person					</a>
									</li>
							<li>
										<a href="https://fellowshipoftheminds.com/2018/06/07/stunning-new-study-found-human-and-all-animal-species-today-originated-only-100000-to-200000-years-ago/" class="bump-view" data-bump-view="tp">
						Stunning new study found human and all animal species today originated only 100,000 to 200,000 years ago					</a>
									</li>
			</ul></li><li id="text-3" class="widget-container widget_text"><h3 class="widget-title">Map of Visitors</h3>			<div class="textwidget"><p><a href="https://clustrmaps.com/site/fkvt" title="Visit tracker"><img src="//www.clustrmaps.com/map_v2.png?d=wuqcbdQ1axgGLD5Pvq6cPpyvzrCj1uaqnWIAUY1NuOU"/></a></p>
</div>
		</li><li id="search-2" class="widget-container widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://fellowshipoftheminds.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></li><li id="author_grid-2" class="widget-container widget_author_grid"><h3 class="widget-title">Who We Are</h3><ul><li><a href="https://fellowshipoftheminds.com/author/daver2112/"> <img alt='' src='https://0.gravatar.com/avatar/60a718cc0ec6b98e0c8be65ca0e0bcdb?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></li><li><a href="https://fellowshipoftheminds.com/author/dcgere/"> <img alt='' src='https://0.gravatar.com/avatar/077726e4d88c858321e6b597eb038bb7?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></li><li><a href="https://fellowshipoftheminds.com/author/eowyn2/"> <img alt='' src='https://0.gravatar.com/avatar/34aa0054fac37d68744e05fe4068c101?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></li><li><a href="https://fellowshipoftheminds.com/author/joandarc/"> <img alt='' src='https://0.gravatar.com/avatar/0d0307c27bffc2f21e9c09b3c2f08fdf?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></li><li><a href="https://fellowshipoftheminds.com/author/traildustfotm/"> <img alt='' src='https://2.gravatar.com/avatar/26acbf761ba5244a8c6617b3bbfa3a9a?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /></a></li></ul></li><li id="authors-2" class="widget-container widget_authors"><h3 class="widget-title">Our Authors&#039; Recent Posts</h3><ul><li><a href="https://fellowshipoftheminds.com/author/daver2112/"> <img alt='' src='https://0.gravatar.com/avatar/60a718cc0ec6b98e0c8be65ca0e0bcdb?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /> <strong>Dave</strong></a><ul><li><a href="https://fellowshipoftheminds.com/2018/05/27/what-memorial-day-is-really-all-about/">What Memorial Day is Really All&nbsp;About</a></li><li><a href="https://fellowshipoftheminds.com/2018/05/04/friday-evening-howler-hogg-claims-trump-is-afraid-of-him/">Friday Evening Howler: Hogg Claims Trump is Afraid of&nbsp;Him</a></li><li><a href="https://fellowshipoftheminds.com/2018/04/23/for-those-suffering-from-the-monday-blahs/">For Those Suffering from the Monday&nbsp;Blahs</a></li><li><a href="https://fellowshipoftheminds.com/2018/03/11/funny-and-thoughtful-church-signs/">Funny (and Thoughtful) Church&nbsp;Signs</a></li><li><a href="https://fellowshipoftheminds.com/2018/03/09/friday-funny-14/">Friday Funny</a></li></ul></li><li><a href="https://fellowshipoftheminds.com/author/dcgere/"> <img alt='' src='https://0.gravatar.com/avatar/077726e4d88c858321e6b597eb038bb7?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /> <strong>DCG</strong></a><ul><li><a href="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/">&#8220;Gangster&#8221; driver in deadly hit &amp; run crash says &#8220;people hit and run people all the&nbsp;time&#8221;</a></li><li><a href="https://fellowshipoftheminds.com/2018/06/08/liberal-utopia-chicago-leads-us-in-underwater-homes/">Liberal utopia: Chicago leads US in underwater&nbsp;homes</a></li><li><a href="https://fellowshipoftheminds.com/2018/06/07/hollyweird-tries-another-all-female-lead-cast-movie-with-oceans-8/">Hollyweird tries another all-female lead cast movie with &#8220;Ocean&#8217;s 8&#8221;</a></li><li><a href="https://fellowshipoftheminds.com/2018/06/07/fight-for-15-mcdonalds-to-add-self-order-kiosks-to-1000-stores-each-quarter/">Fight for $15! McDonald&#8217;s to add self-order kiosks to 1,000 stores each&nbsp;quarter</a></li><li><a href="https://fellowshipoftheminds.com/2018/06/07/political-correctness-at-work-miss-america-is-ending-the-swimsuit-competition/">Political correctness at work: Miss America is ending the swimsuit&nbsp;competition</a></li></ul></li><li><a href="https://fellowshipoftheminds.com/author/eowyn2/"> <img alt='' src='https://0.gravatar.com/avatar/34aa0054fac37d68744e05fe4068c101?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /> <strong>Dr. Eowyn</strong></a><ul><li><a href="https://fellowshipoftheminds.com/2018/06/08/bill-clinton-confronted-at-book-event-about-lolita-express-to-pedo-island/">Bill Clinton confronted at book event about Lolita Express to pedo&nbsp;island</a></li><li><a href="https://fellowshipoftheminds.com/2018/06/08/celebrity-chef-anthony-bourdain-committed-suicide/">Trump-hater celebrity-chef Anthony Bourdain committed&nbsp;suicide</a></li><li><a href="https://fellowshipoftheminds.com/2018/06/07/stunning-new-study-found-human-and-all-animal-species-today-originated-only-100000-to-200000-years-ago/">Stunning new study found human and all animal species today originated only 100,000 to 200,000 years&nbsp;ago</a></li><li><a href="https://fellowshipoftheminds.com/2018/06/07/michigan-state-u-health-physicist-joseph-hattey-arrested-for-dog-rape/">Michigan State U. health physicist Joseph Hattey arrested for dog&nbsp;rape</a></li><li><a href="https://fellowshipoftheminds.com/2018/06/07/dog-says-i-love-you-2/">Dog says &#8216;I love&nbsp;you&#8217;</a></li></ul></li><li><a href="https://fellowshipoftheminds.com/author/joandarc/"> <img alt='' src='https://0.gravatar.com/avatar/0d0307c27bffc2f21e9c09b3c2f08fdf?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /> <strong>joandarc</strong></a><ul><li><a href="https://fellowshipoftheminds.com/2017/11/01/all-saints-day/">All Saints Day</a></li><li><a href="https://fellowshipoftheminds.com/2017/02/14/valentines-day/">St. Valentine</a></li><li><a href="https://fellowshipoftheminds.com/2016/12/16/st-nicholas-model-for-santa-claus/">St. Nicholas, model for Santa&nbsp;Claus</a></li><li><a href="https://fellowshipoftheminds.com/2016/11/05/st-charles-borromeo-patron-saint-of-catechists-and-seminarians/">St. Charles Borromeo, Patron Saint of Catechists and&nbsp;Seminarians</a></li><li><a href="https://fellowshipoftheminds.com/2016/06/29/st-peter-the-rock-2/">St. Peter, the&nbsp;Rock</a></li></ul></li><li><a href="https://fellowshipoftheminds.com/author/traildustfotm/"> <img alt='' src='https://2.gravatar.com/avatar/26acbf761ba5244a8c6617b3bbfa3a9a?s=32&#038;d=wavatar&#038;r=G' class='avatar avatar-32' height='32' width='32' /> <strong>traildustfotm</strong></a><ul><li><a href="https://fellowshipoftheminds.com/2018/06/05/art-school-professor-tells-white-males-to-commit-suicide/">Art School Professor Tells White Males to Commit&nbsp;Suicide</a></li><li><a href="https://fellowshipoftheminds.com/2018/05/31/aloha-snackbar/">Aloha Snackbar</a></li><li><a href="https://fellowshipoftheminds.com/2018/05/29/is-this-the-future-of-las-vegas/">Is this the future of Las Vegas (… or name your&nbsp;city)?</a></li><li><a href="https://fellowshipoftheminds.com/2018/05/28/these-days-we-view-the-old-testament-with-growing-certainty/">These days we view the Old Testament with growing&nbsp;certainty</a></li><li><a href="https://fellowshipoftheminds.com/2018/05/23/he-lifts-his-voice-the-earth-melts/">He Lifts His Voice &#8211; The Earth&nbsp;Melts</a></li></ul></li></ul></li><li id="text-7" class="widget-container widget_text"><h3 class="widget-title">Follow us on Twitter</h3>			<div class="textwidget"><a href="https://twitter.com/DrEowyn" class="twitter-follow-button">Follow @DrEowyn</a>
</div>
		</li><li id="follow_button_widget-2" class="widget-container widget_follow_button_widget">
		<a class="wordpress-follow-button" href="https://fellowshipoftheminds.com" data-blog="https://fellowshipoftheminds.com" data-lang="en" data-show-follower-count="true">Follow Fellowship of the Minds on WordPress.com</a>
		<script type="text/javascript">(function(d){var f = d.getElementsByTagName('SCRIPT')[0], p = d.createElement('SCRIPT');p.type = 'text/javascript';p.async = true;p.src = '//widgets.wp.com/platform.js';f.parentNode.insertBefore(p,f);}(document));</script>

		</li><li id="text-5" class="widget-container widget_text"><h3 class="widget-title">Facebook</h3>			<div class="textwidget"><!-- Facebook Badge START --><a href="http://www.facebook.com/pages/Fellowship-Of-The-Minds/199606000051012" target="_TOP" style="font-family:&quot;font-size:11px;font-variant:normal;font-style:normal;font-weight:normal;color:#3B5998;text-decoration:none;" title="Fellowship Of The Minds">Fellowship Of The Minds</a><br /><a href="http://www.facebook.com/pages/Fellowship-Of-The-Minds/199606000051012" target="_TOP" title="Fellowship Of The Minds"><img src="https://i2.wp.com/badge.facebook.com/badge/199606000051012.2298.1333533823.png" width="120" height="252" style="border:0;" /></a><br /><a href="http://www.facebook.com/business/dashboard/" target="_TOP" style="font-family:&quot;font-size:11px;font-variant:normal;font-style:normal;font-weight:normal;color:#3B5998;text-decoration:none;"><!-- Facebook Badge END -->

</a></div>
		</li><li id="blog_subscription-4" class="widget-container widget_blog_subscription"><h3 class="widget-title"><label for="subscribe-field">Email Subscription</label></h3>
				<form action="https://subscribe.wordpress.com" method="post" accept-charset="utf-8" id="subscribe-blog">
											<p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
<p>Join 9,260 other followers</p>
						<p><input type="text" name="email" style="width: 95%; padding: 1px 2px" placeholder="Enter your email address" value="" id="subscribe-field"/></p>
					
					<p>
						<input type="hidden" name="action" value="subscribe"/>
						<input type="hidden" name="blog_id" value="11081320"/>
						<input type="hidden" name="source" value="https://fellowshipoftheminds.com/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/"/>
						<input type="hidden" name="sub-type" value="widget"/>
						<input type="hidden" name="redirect_fragment" value="blog_subscription-4" />
						<input type="hidden" id="_wpnonce" name="_wpnonce" value="8506f5cd53" />						<input type="submit" value="Sign me up!" />
					</p>
				</form>
			
</li><li id="blog-stats-2" class="widget-container widget_blog-stats"><h3 class="widget-title">Blog stats since 23 December 2009</h3>		<ul>
			<li>37,420,831 hits</li>
		</ul>
		</li><li id="meta-4" class="widget-container widget_meta"><h3 class="widget-title">Meta</h3>			<ul>
			<li><a href="https://wordpress.com/start?ref=wplogin">Register</a></li>			<li><a href="https://fellowshipofminds.wordpress.com/wp-login.php">Log in</a></li>
			<li><a href="https://fellowshipoftheminds.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://fellowshipoftheminds.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.com/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.com</a></li>			</ul>
			</li><li id="linkcat-1356" class="widget-container widget_links"><h3 class="widget-title">Blogroll</h3>
	<ul class='xoxo blogroll'>
<li><a href="https://www.dropbox.com/s/we0gm4m7ymjlqlr/100BPls%282%29.odt" title="FREE tips on horticulture &amp; landscaping by Joseph Fasciani">100 Best Plants and How to Use Them</a></li>
<li><a href="http://neprimer.com/1963ComGoals.htm">45 Communist Goals for America</a></li>
<li><a href="http://www.numberofabortions.com/" title="Number of abortions USA and worldwide">Abortion Clock</a></li>
<li><a href="https://bill-mcentee.pixels.com/" title="Talented artist in the tradition of French Impressionist Monet ">Bill McEntee Artist Website</a></li>
<li><a href="http://www.campusreform.org/" title="Outstanding site exposing the virus of Leftism infesting America&#8217;s colleges &amp; universities">Campus Reform</a></li>
<li><a href="https://cinderellabroom.wordpress.com/" title="Excellent research on all matters Sandy Hook">Cinderella&#039;s Broom</a></li>
<li><a href="http://constitutionus.com/">Constitution of the United States of America</a></li>
<li><a href="http://www.fakehatecrimes.org/">Fake Hate Crimes</a></li>
<li><a href="http://www.henrymakow.com/" title="Culture war">Henry Makow</a></li>
<li><a href="http://www.answering-islam.org/Authors/Arlandson/jihad.htm" title="The truth about jihad as violent war against infidels, in contrast to Christianity">Jihad in Quran and Hadith</a></li>
<li><a href="http://www.MarkSMcGrew.net" title="One of the first, if not the first, to write about Obama&#8217;s birth ineligibility to be POTUS">Mark McGrew</a></li>
<li><a href="http://memoryholeblog.org/" title="James Tracy&#8217;s blog is back!">Memory Hole Blog</a></li>
<li><a href="http://stateofthenation2012.com/?p=68600" title="Detailed presentation of the many facets of PizzaGate &amp; PedoGate">PedoGate</a></li>
<li><a href="https://fellowshipofminds.files.wordpress.com/2017/03/pizzagate_4_dummies_pchr.pdf">Pizzagate For Dummies</a></li>
<li><a href="http://www.prayinjesusname.org/" title="Sending petitions to God and government to defend religious freedom">Pray In Jesus Name Project</a></li>
<li><a href="http://www.professorwatchlist.org/index.php" title="Professors who advance a radical Left agenda in lecture halls">Professor Watchlist</a></li>
<li><a href="https://fellowshipoftheminds.com/2014/09/10/the-lefts-playbook-satanist-saul-alinskys-13-rules-for-political-warfare/" title="The tactics are used not just by leftists, but are a hallmark of satanists">Saul Alinsky&#039;s 13 Rules for Political Warfare</a></li>
<li><a href="http://www.sitchiniswrong.com/" title="A scholar in ancient Semitic languages debunks Zecharia Sitchin">Sitchin Is Wrong</a></li>
<li><a href="http://splcexposed.com/" title="Exposing Southern Poverty Law Center as a hate grouup">SPLC Exposed</a></li>
<li><a href="http://www.stevequayle.com/">Steve Quayle</a></li>
<li><a href="http://www.dcclothesline.com" title="New blog by a great conservative patriot">The D. C. Clothesline</a></li>
<li><a href="http://www.deliberatedumbingdown.com/" title="Free version of Charlotte Iserbyt&#8217;s book!">The Deliberate Dumbing Down of America</a></li>
<li><a href="http://www.transgenderchildabuse.com" title="Website of Alex Serritella, author of an important book, Transgenda &#8211; Abuse and Regret in the Sex-Change Industry">Transgender Child Abuse</a></li>
<li><a href="http://www.illegalaliencrimereport.com/">U.S. Illegal Alien Crime Report</a></li>
<li><a href="http://www.usdebtclock.org/">U.S. National Debt Clock</a></li>

	</ul>
</li>
<li id="archives-3" class="widget-container widget_archive"><h3 class="widget-title">Archives</h3>		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='https://fellowshipoftheminds.com/2018/06/'> June 2018 </option>
	<option value='https://fellowshipoftheminds.com/2018/05/'> May 2018 </option>
	<option value='https://fellowshipoftheminds.com/2018/04/'> April 2018 </option>
	<option value='https://fellowshipoftheminds.com/2018/03/'> March 2018 </option>
	<option value='https://fellowshipoftheminds.com/2018/02/'> February 2018 </option>
	<option value='https://fellowshipoftheminds.com/2018/01/'> January 2018 </option>
	<option value='https://fellowshipoftheminds.com/2017/12/'> December 2017 </option>
	<option value='https://fellowshipoftheminds.com/2017/11/'> November 2017 </option>
	<option value='https://fellowshipoftheminds.com/2017/10/'> October 2017 </option>
	<option value='https://fellowshipoftheminds.com/2017/09/'> September 2017 </option>
	<option value='https://fellowshipoftheminds.com/2017/08/'> August 2017 </option>
	<option value='https://fellowshipoftheminds.com/2017/07/'> July 2017 </option>
	<option value='https://fellowshipoftheminds.com/2017/06/'> June 2017 </option>
	<option value='https://fellowshipoftheminds.com/2017/05/'> May 2017 </option>
	<option value='https://fellowshipoftheminds.com/2017/04/'> April 2017 </option>
	<option value='https://fellowshipoftheminds.com/2017/03/'> March 2017 </option>
	<option value='https://fellowshipoftheminds.com/2017/02/'> February 2017 </option>
	<option value='https://fellowshipoftheminds.com/2017/01/'> January 2017 </option>
	<option value='https://fellowshipoftheminds.com/2016/12/'> December 2016 </option>
	<option value='https://fellowshipoftheminds.com/2016/11/'> November 2016 </option>
	<option value='https://fellowshipoftheminds.com/2016/10/'> October 2016 </option>
	<option value='https://fellowshipoftheminds.com/2016/09/'> September 2016 </option>
	<option value='https://fellowshipoftheminds.com/2016/08/'> August 2016 </option>
	<option value='https://fellowshipoftheminds.com/2016/07/'> July 2016 </option>
	<option value='https://fellowshipoftheminds.com/2016/06/'> June 2016 </option>
	<option value='https://fellowshipoftheminds.com/2016/05/'> May 2016 </option>
	<option value='https://fellowshipoftheminds.com/2016/04/'> April 2016 </option>
	<option value='https://fellowshipoftheminds.com/2016/03/'> March 2016 </option>
	<option value='https://fellowshipoftheminds.com/2016/02/'> February 2016 </option>
	<option value='https://fellowshipoftheminds.com/2016/01/'> January 2016 </option>
	<option value='https://fellowshipoftheminds.com/2015/12/'> December 2015 </option>
	<option value='https://fellowshipoftheminds.com/2015/11/'> November 2015 </option>
	<option value='https://fellowshipoftheminds.com/2015/10/'> October 2015 </option>
	<option value='https://fellowshipoftheminds.com/2015/09/'> September 2015 </option>
	<option value='https://fellowshipoftheminds.com/2015/08/'> August 2015 </option>
	<option value='https://fellowshipoftheminds.com/2015/07/'> July 2015 </option>
	<option value='https://fellowshipoftheminds.com/2015/06/'> June 2015 </option>
	<option value='https://fellowshipoftheminds.com/2015/05/'> May 2015 </option>
	<option value='https://fellowshipoftheminds.com/2015/04/'> April 2015 </option>
	<option value='https://fellowshipoftheminds.com/2015/03/'> March 2015 </option>
	<option value='https://fellowshipoftheminds.com/2015/02/'> February 2015 </option>
	<option value='https://fellowshipoftheminds.com/2015/01/'> January 2015 </option>
	<option value='https://fellowshipoftheminds.com/2014/12/'> December 2014 </option>
	<option value='https://fellowshipoftheminds.com/2014/11/'> November 2014 </option>
	<option value='https://fellowshipoftheminds.com/2014/10/'> October 2014 </option>
	<option value='https://fellowshipoftheminds.com/2014/09/'> September 2014 </option>
	<option value='https://fellowshipoftheminds.com/2014/08/'> August 2014 </option>
	<option value='https://fellowshipoftheminds.com/2014/07/'> July 2014 </option>
	<option value='https://fellowshipoftheminds.com/2014/06/'> June 2014 </option>
	<option value='https://fellowshipoftheminds.com/2014/05/'> May 2014 </option>
	<option value='https://fellowshipoftheminds.com/2014/04/'> April 2014 </option>
	<option value='https://fellowshipoftheminds.com/2014/03/'> March 2014 </option>
	<option value='https://fellowshipoftheminds.com/2014/02/'> February 2014 </option>
	<option value='https://fellowshipoftheminds.com/2014/01/'> January 2014 </option>
	<option value='https://fellowshipoftheminds.com/2013/12/'> December 2013 </option>
	<option value='https://fellowshipoftheminds.com/2013/11/'> November 2013 </option>
	<option value='https://fellowshipoftheminds.com/2013/10/'> October 2013 </option>
	<option value='https://fellowshipoftheminds.com/2013/09/'> September 2013 </option>
	<option value='https://fellowshipoftheminds.com/2013/08/'> August 2013 </option>
	<option value='https://fellowshipoftheminds.com/2013/07/'> July 2013 </option>
	<option value='https://fellowshipoftheminds.com/2013/06/'> June 2013 </option>
	<option value='https://fellowshipoftheminds.com/2013/05/'> May 2013 </option>
	<option value='https://fellowshipoftheminds.com/2013/04/'> April 2013 </option>
	<option value='https://fellowshipoftheminds.com/2013/03/'> March 2013 </option>
	<option value='https://fellowshipoftheminds.com/2013/02/'> February 2013 </option>
	<option value='https://fellowshipoftheminds.com/2013/01/'> January 2013 </option>
	<option value='https://fellowshipoftheminds.com/2012/12/'> December 2012 </option>
	<option value='https://fellowshipoftheminds.com/2012/11/'> November 2012 </option>
	<option value='https://fellowshipoftheminds.com/2012/10/'> October 2012 </option>
	<option value='https://fellowshipoftheminds.com/2012/09/'> September 2012 </option>
	<option value='https://fellowshipoftheminds.com/2012/08/'> August 2012 </option>
	<option value='https://fellowshipoftheminds.com/2012/07/'> July 2012 </option>
	<option value='https://fellowshipoftheminds.com/2012/06/'> June 2012 </option>
	<option value='https://fellowshipoftheminds.com/2012/05/'> May 2012 </option>
	<option value='https://fellowshipoftheminds.com/2012/04/'> April 2012 </option>
	<option value='https://fellowshipoftheminds.com/2012/03/'> March 2012 </option>
	<option value='https://fellowshipoftheminds.com/2012/02/'> February 2012 </option>
	<option value='https://fellowshipoftheminds.com/2012/01/'> January 2012 </option>
	<option value='https://fellowshipoftheminds.com/2011/12/'> December 2011 </option>
	<option value='https://fellowshipoftheminds.com/2011/11/'> November 2011 </option>
	<option value='https://fellowshipoftheminds.com/2011/10/'> October 2011 </option>
	<option value='https://fellowshipoftheminds.com/2011/09/'> September 2011 </option>
	<option value='https://fellowshipoftheminds.com/2011/08/'> August 2011 </option>
	<option value='https://fellowshipoftheminds.com/2011/07/'> July 2011 </option>
	<option value='https://fellowshipoftheminds.com/2011/06/'> June 2011 </option>
	<option value='https://fellowshipoftheminds.com/2011/05/'> May 2011 </option>
	<option value='https://fellowshipoftheminds.com/2011/04/'> April 2011 </option>
	<option value='https://fellowshipoftheminds.com/2011/03/'> March 2011 </option>
	<option value='https://fellowshipoftheminds.com/2011/02/'> February 2011 </option>
	<option value='https://fellowshipoftheminds.com/2011/01/'> January 2011 </option>
	<option value='https://fellowshipoftheminds.com/2010/12/'> December 2010 </option>
	<option value='https://fellowshipoftheminds.com/2010/11/'> November 2010 </option>
	<option value='https://fellowshipoftheminds.com/2010/10/'> October 2010 </option>
	<option value='https://fellowshipoftheminds.com/2010/09/'> September 2010 </option>
	<option value='https://fellowshipoftheminds.com/2010/08/'> August 2010 </option>
	<option value='https://fellowshipoftheminds.com/2010/07/'> July 2010 </option>
	<option value='https://fellowshipoftheminds.com/2010/06/'> June 2010 </option>
	<option value='https://fellowshipoftheminds.com/2010/05/'> May 2010 </option>
	<option value='https://fellowshipoftheminds.com/2010/04/'> April 2010 </option>
	<option value='https://fellowshipoftheminds.com/2010/03/'> March 2010 </option>
	<option value='https://fellowshipoftheminds.com/2010/02/'> February 2010 </option>
	<option value='https://fellowshipoftheminds.com/2010/01/'> January 2010 </option>
	<option value='https://fellowshipoftheminds.com/2009/12/'> December 2009 </option>

		</select>
		</li><li id="twitter_timeline-3" class="widget-container widget_twitter_timeline"><h3 class="widget-title">Follow me on Twitter</h3><a class="twitter-timeline" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-tweet-limit="5" data-lang="EN" data-partner="jetpack" data-chrome="noheader nofooter noborders transparent" href="https://twitter.com/@DrEowyn" href="https://twitter.com/@DrEowyn">My Tweets</a></li>			</ul>
		</div><!-- #primary .widget-area -->

		
			</div><!-- #content-box -->

	<div id="footer" role="contentinfo">
		
		<div id="colophon">
			<span class="generator-link"></span>
					</div><!-- #colophon -->
	</div><!-- #footer -->

</div><!-- #container -->

<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201823y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	<div class="grofile-hash-map-26acbf761ba5244a8c6617b3bbfa3a9a">
	</div>
	<div class="grofile-hash-map-077726e4d88c858321e6b597eb038bb7">
	</div>
	<div class="grofile-hash-map-61a50fccf49ac1e74c38d16ed6fe4909">
	</div>
	<div class="grofile-hash-map-d2b8c715ff5e3c9231c9d3faeb8af556">
	</div>
	<div class="grofile-hash-map-4a2e5258ecfdef755096b915bbfd708a">
	</div>
	<div class="grofile-hash-map-a15303fecdd1dfe49563f4a9b7dc9405">
	</div>
	<div class="grofile-hash-map-b3e4f8f465083fbf529f0795fce16627">
	</div>
	<div class="grofile-hash-map-186121ea9406612e65966291d8f6e11c">
	</div>
	<div class="grofile-hash-map-0aaf63a57f9351266e751c4f208250d9">
	</div>
	<div class="grofile-hash-map-784a881895e046f7e0dbe97a2ad4a73a">
	</div>
	<div class="grofile-hash-map-8aeee22ba9c87136b92c3658811be677">
	</div>
	<div class="grofile-hash-map-f962fc516e22acae7818ebcc0970703d">
	</div>
	<div class="grofile-hash-map-8d176bb7f821007943379ebd94765595">
	</div>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/fellowshipofminds.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/fellowshipofminds.wordpress.com\/wp-login.php?action=logout&_wpnonce=7a75332113","homeURL":"https:\/\/fellowshipoftheminds.com\/","postID":"164952","gravDefault":"wavatar","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1521806916j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="11081320" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://fellowshipoftheminds.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="Fellowship of the Minds" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="3b93e72d0b" /><input type="hidden" name="_wp_http_referer" value="/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/" />		</form>

		<div class="arrow"></div>
	</div>
<script type='text/javascript' charset='UTF-8' id='polldaddyRatings'><!--//--><![CDATA[//><!--
PDRTJS_settings_1006935_post_164952={"id":1006935,"unique_id":"wp-post-164952","title":"%26%238220%3BGangster%26%238221%3B%20driver%20in%20deadly%20hit%20%26amp%3B%20run%20crash%20says%20%26%238220%3Bpeople%20hit%20and%20run%20people%20all%20the%26nbsp%3Btime%26%238221%3B","permalink":"https:\/\/fellowshipoftheminds.com\/2018\/06\/08\/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time\/","item_id":"_post_164952"}; if ( typeof PDRTJS_RATING !== 'undefined' ){if ( typeof PDRTJS_1006935_post_164952 == 'undefined' ){PDRTJS_1006935_post_164952 = new PDRTJS_RATING( PDRTJS_settings_1006935_post_164952 );}}
//--><!]]></script><script type='text/javascript' charset='UTF-8' src='https://polldaddy.com/js/rating/rating.js'></script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/fellowshipoftheminds.com\/2018\/06\/08\/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time\/":164952};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/2018/06/08/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<div
				class="g-recaptcha"
				data-sitekey="6LcmyE0UAAAAALID28yVNg7pFCodGaArJzHitez_"
				data-theme="light"
				data-type="image"
				data-tabindex="0"></div>
			<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en" async></script>
			
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<link rel='stylesheet' id='all-css-0-3' href='https://s2.wp.com/_static/??/wp-content/mu-plugins/widgets/author-grid/author-grid.css,/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1524699534j&cssminify=yes' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"11081320","siteName":"Fellowship of the Minds","siteURL":"https:\/\/fellowshipoftheminds.com","icon":"<img alt='' src='https:\/\/secure.gravatar.com\/blavatar\/b44e87079ce3dd384b698212658e7198?s=50&d=https%3A%2F%2Fs2.wp.com%2Fi%2Flogo%2Fwpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/coraline","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/fellowshipofminds.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Ffellowshipoftheminds.com%2F2018%2F06%2F08%2Fgangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time%2F","themeURL":"","xhrURL":"https:\/\/fellowshipoftheminds.com\/wp-admin\/admin-ajax.php","nonce":"6cbab63718","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"8506f5cd53\" \/>","referer":"https:\/\/fellowshipoftheminds.com\/2018\/06\/08\/gangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time\/","canFollow":"1","feedID":"14041240","statusMessage":"","customizeLink":"https:\/\/fellowshipofminds.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Ffellowshipofminds.wordpress.com%2F2018%2F06%2F08%2Fgangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time%2F","postID":"164952","shortlink":"https:\/\/wp.me\/pKuKY-GUw","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/fellowshipoftheminds.com\/164952","statsLink":"https:\/\/wordpress.com\/stats\/post\/164952\/fellowshipoftheminds.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Coraline","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 9,260 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/fellowshipofminds.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Ffellowshipoftheminds.com%2F2018%2F06%2F08%2Fgangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/fellowshipoftheminds.com\/wp-admin\/admin-ajax.php","nonce":"19ac8cc1f9","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/fellowshipofminds.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Ffellowshipoftheminds.com%2F2018%2F06%2F08%2Fgangster-driver-in-deadly-hit-run-crash-says-people-hit-and-run-people-all-the-time%2F","blog_id":"11081320","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=11081320&v=wpcom&tz=-7&user_id=0&subd=fellowshipofminds","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyVkV1OwzAQhC+EYygqEQ+IoyDX2bbr+I/ddUNvj6OSkkqVpT6tNZ5vtB7rKSubokAU7VgPcEIL+adz/KRXV6Go7MsBI2uPI7D+LlDgaOLggRpmm0KokrpAbqZ3mifM8Ah0IywgRuvLcGsgyP7cBYyNdAeSjR31Vw3QMqEIkBIM4DG2tjJDzVU7QzoYrkw9qXQCIpyXuGoPJgjVXbgFWcEUZ+h6utcA5/9Hr3VXP4rOf6Nbu+4VbygVBr90pBahtd+IHEDUa/d8qXSfKDT8ObGovTdImo+GMB6WWaHP8PGy3Ww3ff/Wv7tfiVD5/A=='></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-skype', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomskype', 'menubar=1,resizable=1,width=305,height=665' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20180319#ver=20180319' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'11081320','blog_tz':'-7','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'11081320','v':'wpcom','tz':'-7','user_id':'0','post':'164952','subd':'fellowshipofminds'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1hV3xrb2xUT3JBbjREZWgvK29XZW1dcW9pNnd3Rkx0fHowaGR0UVFtVEgydVprSi4wWVNNK2MvSVpXLy89OThPQklGfC8mK1txZmpBdlMuTEtNc093UTNrUFoxMHMmRFNDV0dxSHM4KzZRVT9mZC0/TGJZSjc1Q25FTWYyU0RaTmZhPWs4RD9TLkFDREdiSFNMTEpjJlk4MHBydT02bFNlUDM0QlRhYkIyMUQmbnlIM2lQcEUwelhOYi4rN2YveGF3WTBLd0lMaG16YU1VNGMlUVk5M2IsdkYzWiZNJjdVdWZYLzNoM2o1Z0JlW2VaaFEtcmJda35dbUh3ayxGYVc9WXdULS5rR0slenF4TUlQR000RS9NUi1vSVE9Z3JsLDFmXz9Jd0tKbXp0Q3NEOSxzNy55WlY1TSZjMmR3UzFiTCxRTV9ibDBQc2d4RmtxU1dYSGtNZVB5UnoraDNSJjcxOVlhL19hcEl0dnxzfnlddFdm'}]);
_stq.push([ 'clickTrackerInit', '11081320', '164952' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>
<!--
	generated in 0.256 seconds
	124835 bytes batcached for 300 seconds
-->
